Back to overview
Downtime

Degraded Performance on Client Websites Following Overnight Update

Dec 24 at 02:32am GMT
Affected services
Hosting Services

Resolved
Dec 24 at 11:42am GMT

A fix has been successfully deployed to all hosted WordPress sites. This has resolved the issues previously experienced, including slow load times and menu display errors on mobile devices.

We apologise for any inconvenience caused. The platform continues to be monitored over the next few hours, and so far, no further issues previously seen have been reported.

Updated
Dec 24 at 08:37am GMT

Following overnight work with LiteSpeed, the issue affecting client websites has now been identified. To restore correct functionality, a restoration will take place at 09:00 to revert all affected hosted sites to a previous backup.

During the restoration window, WordPress admin access will be temporarily disabled to prevent any amendments while the process is completed. This action will only impact WordPress sites; non-WordPress sites are not impacted by this issue.

A permanent fix is currently being worked on in parallel, and the issue continues to be actively investigated. Further updates will be provided as progress is made.

Created
Dec 24 at 02:32am GMT

Following an overnight upgrade and patching process, degraded performance has been identified across a number of client websites. Some websites are experiencing slow page load times, and in certain cases, menu items are not displaying correctly on mobile devices.

This issue is currently being investigated by Webterior in collaboration with the third-party software vendor. Initial findings suggest the behaviour is likely related to a LiteSpeed cache update applied overnight.

The incident is being treated as high priority, and work is ongoing to identify the root cause and restore normal performance as quickly as possible. Further updates will be provided as more information becomes available.