Access restricted to cPanel, WHM & Webmail
Resolved
Apr 30, 2026 at 8:13am UTC
Issue resolved.
Affected services
Updated
Apr 30, 2026 at 6:11am UTC
We have now completed work to patch all impacted resources. Full acces has been restored and no further impact has been observed.
Affected services
Created
Apr 28, 2026 at 7:13pm UTC
We're currently applying precautionary restrictions to cPanel, WHM, and Webmail access following this recently disclosed security vulnerability affecting cPanel -
This is a proactive step to remove any exposure while we await patches from cPanel.
All customer websites, email delivery, and core hosting services remain fully operational. The changes are limited to cPanel and Webmail access only.
We will restore normal access as soon as we have received confirmation from cPanel.
We appreciate your understanding. As always, if you have any questions, our team is here to help.
Affected services