Back to overview
Downtime
UK Domain Management Unavailable
Feb 25, 2026 at 03:00pm UTC
Affected services
Domain Name Services
Resolved
Feb 25, 2026 at 04:14pm UTC
Thank you for your patience. This has now been resolved.
Affected services
Created
Feb 25, 2026 at 03:00pm UTC
We are currently aware of issues when managing UK domain names through our client area. This does appear to be isolated with the Nominet API currently experiencing issues, but we will be investigating further and will keep this status page updated as we know more.
Affected services