Back to overview
Degraded

SSL Certificate & Email Connectivity Issues

Oct 20 at 01:00pm BST
Affected services
Hosting Services

Resolved
Oct 25 at 11:45pm BST

Following a period of testing. All SSL Certificates at the root of all customer domains have been re-issued. This incident is now resolved.

Created
Oct 20 at 01:00pm BST

We are currently aware of a number of users encountering errors with Mail Clients and Browsers being unable to verify the server identity.

As of September 2021, our third party SSL Provider dropped support for their older root CA. This change has resulted in a number of users encountering errors with their Mail Clients being unable to verify the server identity.

Following a period of testing and to resolve issues we'll be completing emergency maintenance between 13:00 - 14:30 this afternoon (20th October). We'll reissue the SSL Certificate at the root of all customer domains.

Please Note: This is not a Webterior-specific issue. Any software (web browsers, Mail Clients) impacted by this will also be unable to connect to any other web sites or mail servers which use Let's Encrypt. Once the work has been completed, you will need to restart any devices (Laptops, Mobiles, PC's etc) that were previously encountering the SSL issue to ensure the device cache is cleared!

Further information can be found via: https://portal.webterior.co.uk/knowledgebase/44/Cannot-Verify-Server-Identity-SSL-error.html