Payment Issues
Resolved
Feb 08 at 01:14am GMT
All client records have now been corrected, we continue to investigate the root cause with our third party.
Affected services
Updated
Feb 08 at 12:16am GMT
A third party sync between Webterior Servers and our Domain registrar has caused some domain expiry dates to be reset to 00/00/0000 causing invoices to be generated and late fees added. We're now working to resync domain to include correct registered and expiry dates.
All created invoices have been cancelled and where necessary payments refunded, we apologise to impacted customers.
We'll continue to investigate the issue with our Third Party and provide an update as soon as possible.
Affected services
Created
Feb 08 at 12:06am GMT
We are currently investigating a payment processing error which has resulted in invoices being incorrectly generated; All pending transactions have been stopped, and will be refunded accordingly.
We apologise for any inconvenience, if you still require support please email hi@webterior.co.uk
Affected services