Back to overview
Degraded

Virgin Media: Global Outage

Apr 27 at 05:00pm BST
Affected services
Hosting Services
Network & Connectivity
Webterior
Webterior Customer Hub
Customer Hub Email Import

Resolved
Apr 28 at 08:43am BST

This incident has now been resolved following re-distribution of traffic and Virgin Media Outage being resolved.

Updated
Apr 27 at 05:15pm BST

Our Data Centre is currently experiencing intermittent network issues which is impacting all Webterior Hosting Services.

Virgin Media have reported a Global Outage impacting it's services which we understand are causing a knock-on effect to Webterior.

We are now working with our teams to re-distribute traffic across the network and anticipate that services will experience degraded performance.

Created
Apr 27 at 05:00pm BST

We're currently experiencing intermittent network issues.